What’s Vulnerable › Vulnerabilities
CVE-2023-28440: Denial of service via admin theme import route in Discourse
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-18 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open source platform for community discussion. In affected versions a maliciously crafted request from a Discourse administrator can lead to a long-running request and eventual timeout. This has the greatest potential impact in shared hosting environments where admins are untrusted. This issue has been addressed in versions 3.0.3 and 3.1.0.beta4. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- discourse: before 3.0.3; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+203) — fixed in 3.0.3
How to fix
Upgrade to a fixed version: discourse 3.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-vm65-pv5h-6g3w
- https://github.com/discourse/discourse/security/advisories/GHSA-vm65-pv5h-6g3w
Get alerted when CVE-2023-28440 or the next vulnerability affects your stack