What’s Vulnerable › Vulnerabilities
CVE-2023-28446: Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-24 · updated 2026-06-17
- Weakness: CWE-150
Description
Deno is a simple, modern and secure runtime for JavaScript and TypeScript that uses V8 and is built in Rust. Arbitrary program names without any ANSI filtering allows any malicious program to clear the first 2 lines of a `op_spawn_child` or `op_kill` prompt and replace it with any desired text. This works with any command on the respective platform, giving the program the full ability to choose what program they wanted to run. This problem can not be exploited on systems that do not attach an interactive prompt (for example headless servers). This issue has been patched in version 1.31.2.
Affected products
- denoland deno: before 1.31.2 — fixed in 1.31.2
How to fix
Upgrade to a fixed version: denoland deno 1.31.2. Check the vendor advisory for mitigations.
References
- https://github.com/denoland/deno/blob/7d13d65468c37022f003bb680dfbddd07ea72173/runtime/js/40_process.js#L175
- https://github.com/denoland/deno/releases/tag/v1.31.2
- https://github.com/denoland/deno/security/advisories/GHSA-vq67-rp93-65qf
- https://github.com/denoland/deno/blob/7d13d65468c37022f003bb680dfbddd07ea72173/runtime/js/40_process.js#L175
- https://github.com/denoland/deno/releases/tag/v1.31.2
- https://github.com/denoland/deno/security/advisories/GHSA-vq67-rp93-65qf
Get alerted when CVE-2023-28446 or the next vulnerability affects your stack