What’s Vulnerable › Vulnerabilities
CVE-2023-2847: Local privilege escalation in ESET products for Linux and MacOS
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-15 · updated 2026-06-17
- Weakness: CWE-269
Description
During internal security analysis, a local privilege escalation vulnerability has been identified. On a machine with the affected ESET product installed, it was possible for a user with lower privileges due to improper privilege management to trigger actions with root privileges. ESET remedied this possible attack vector and has prepared new builds of its products that are no longer susceptible to this vulnerability.
Affected products
- ESET Cyber Security: from 7.3.0 before 7.3.3700.0 — fixed in 7.3.3700.0
- ESET Endpoint Antivirus: before 8.1.12.0; from 7.0.0 before 7.3.3600.0; from 9.0.5.0 before 9.0.10.0; from 9.1.4.0 before 9.1.11.0 — fixed in 7.3.3600.0, 8.1.12.0, 9.0.10.0, 9.1.11.0
- ESET Server Security: before 8.1.823.0; from 9.0.464.0 before 9.0.466.0; from 9.1.96.0 before 9.1.98.0 — fixed in 8.1.823.0, 9.0.466.0, 9.1.98.0
How to fix
Upgrade to a fixed version: ESET Cyber Security 7.3.3700.0; ESET Endpoint Antivirus 7.3.3600.0, 8.1.12.0, 9.0.10.0, 9.1.11.0; ESET Server Security 8.1.823.0, 9.0.466.0, 9.1.98.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-2847 or the next vulnerability affects your stack