What’s Vulnerable › Vulnerabilities
CVE-2023-2848
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-14 · updated 2026-06-17
- Weakness: CWE-1385
Description
Movim prior to version 0.22 is affected by a Cross-Site WebSocket Hijacking vulnerability. This was the result of a missing header validation.
Affected products
- Movim: before 0.22 — fixed in 0.22
How to fix
Upgrade to a fixed version: Movim 0.22. Check the vendor advisory for mitigations.
References
- https://github.com/movim/movim/commit/49e2012aecdf918bb1d16f278fa9ff42fad29a9d
- https://github.com/movim/movim/commit/96372082acd3e5d778a2522a60a1805bf2af31f6
- https://mov.im/node/pubsub.movim.eu/Movim/a2d05925-0427-4f3f-b777-d20571ddddff
- https://github.com/movim/movim/commit/49e2012aecdf918bb1d16f278fa9ff42fad29a9d
- https://github.com/movim/movim/commit/96372082acd3e5d778a2522a60a1805bf2af31f6
- https://mov.im/node/pubsub.movim.eu/Movim/a2d05925-0427-4f3f-b777-d20571ddddff
Get alerted when CVE-2023-2848 or the next vulnerability affects your stack