What’s Vulnerable › Vulnerabilities
CVE-2023-2850
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-25 · updated 2026-06-17
- Weakness: CWE-1385
Description
NodeBB is affected by a Cross-Site WebSocket Hijacking vulnerability due to missing validation of the request origin. Exploitation of this vulnerability allows certain user information to be extracted by attacker.
Affected products
- NodeBB: before 2.8.13; from 3.0.0 before 3.1.3 — fixed in 2.8.13, 3.1.3
How to fix
Upgrade to a fixed version: NodeBB 2.8.13, 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/NodeBB/NodeBB/commit/51096ad2345fb1d1380bec0a447113489ef6c359
- https://github.com/NodeBB/NodeBB/releases/tag/v3.1.3
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-4qcv-qf38-5j3j
- https://github.com/NodeBB/NodeBB/commit/51096ad2345fb1d1380bec0a447113489ef6c359
- https://github.com/NodeBB/NodeBB/releases/tag/v3.1.3
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-4qcv-qf38-5j3j
Get alerted when CVE-2023-2850 or the next vulnerability affects your stack