What’s Vulnerable › Vulnerabilities
CVE-2023-28522: IBM API Connect improper access control
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-12 · updated 2026-06-17
- Weakness: CWE-732
Description
IBM API Connect V10 could allow an authenticated user to perform actions that they should not have access to. IBM X-Force ID: 250585.
Affected products
- IBM API Connect: from 10.0.0.0 before 10.0.1.11; from 10.0.2.0 before 10.0.5.2 — fixed in 10.0.1.11, 10.0.5.2
How to fix
Upgrade to a fixed version: IBM API Connect 10.0.1.11, 10.0.5.2. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/250585
- https://www.ibm.com/support/pages/node/6965612
- https://exchange.xforce.ibmcloud.com/vulnerabilities/250585
- https://www.ibm.com/support/pages/node/6965612
Get alerted when CVE-2023-28522 or the next vulnerability affects your stack