What’s Vulnerable › Vulnerabilities
CVE-2023-2856
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-26 · updated 2026-06-17
- Weakness: CWE-787
Description
VMS TCPIPtrace file parser crash in Wireshark 4.0.0 to 4.0.5 and 3.6.0 to 3.6.13 allows denial of service via crafted capture file
Affected products
- Debian Linux: 10.0, 12.0
- Wireshark Foundation Wireshark: from 3.6.0 before 3.6.14; from 4.0.0 before 4.0.6 — fixed in 3.6.14, 4.0.6
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 3.6.14, 4.0.6. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-2856.json
- https://gitlab.com/wireshark/wireshark/-/issues/19083
- https://lists.debian.org/debian-lts-announce/2023/06/msg00004.html
- https://security.gentoo.org/glsa/202309-02
- https://www.debian.org/security/2023/dsa-5429
- https://www.wireshark.org/security/wnpa-sec-2023-16.html
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-2856.json
- https://gitlab.com/wireshark/wireshark/-/issues/19083
- https://lists.debian.org/debian-lts-announce/2023/06/msg00004.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00049.html
- https://security.gentoo.org/glsa/202309-02
- https://www.debian.org/security/2023/dsa-5429
Get alerted when CVE-2023-2856 or the next vulnerability affects your stack