What’s Vulnerable › Vulnerabilities
CVE-2023-28609
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-18 · updated 2026-06-17
- Weakness: CWE-287
Description
api/auth.go in Ansible Semaphore before 2.8.89 mishandles authentication.
Affected products
- Ansible-Semaphore Ansible Semaphore: before 2.8.89 — fixed in 2.8.89
How to fix
Upgrade to a fixed version: Ansible-Semaphore Ansible Semaphore 2.8.89. Check the vendor advisory for mitigations.
References
- https://github.com/ansible-semaphore/semaphore/commit/3e4a62b7f2b1ef0660c9fb839818a53c80a5a8b1
- https://github.com/ansible-semaphore/semaphore/releases/tag/v2.8.89
- https://github.com/ansible-semaphore/semaphore/commit/3e4a62b7f2b1ef0660c9fb839818a53c80a5a8b1
- https://github.com/ansible-semaphore/semaphore/releases/tag/v2.8.89
Get alerted when CVE-2023-28609 or the next vulnerability affects your stack