What’s Vulnerable › Vulnerabilities
CVE-2023-28616
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-26 · updated 2026-06-17
- Weakness: CWE-319
Description
An issue was discovered in Stormshield Network Security (SNS) before 4.3.17, 4.4.x through 4.6.x before 4.6.4, and 4.7.x before 4.7.1. It affects user accounts for which the password has an equals sign or space character. The serverd process logs such passwords in cleartext, and potentially sends these logs to the Syslog component.
Affected products
- Stormshield Network Security: from 2.7.0 before 4.3.17; from 4.4.0 before 4.6.4; 4.7.0 — fixed in 4.3.17, 4.6.4
How to fix
Upgrade to a fixed version: Stormshield Network Security 4.3.17, 4.6.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-28616 or the next vulnerability affects your stack