What’s Vulnerable › Vulnerabilities
CVE-2023-28629: Stored XSS possible on VSM and Job Details pages via malicious pipeline label configuration in gocd
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
GoCD is an open source continuous delivery server. GoCD versions before 23.1.0 are vulnerable to a stored XSS vulnerability, where pipeline configuration with a malicious pipeline label configuration can affect browser display of pipeline runs generated from that configuration. An attacker that has permissions to configure GoCD pipelines could include JavaScript elements within the label template, causing a XSS vulnerability to be triggered for any users viewing the Value Stream Map or Job Details for runs of the affected pipeline, potentially allowing them to perform arbitrary actions within the victim's browser context rather than their own. This issue has been fixed in GoCD 23.1.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- gocd: before 23.1.0 — fixed in 23.1.0
How to fix
Upgrade to a fixed version: gocd 23.1.0. Check the vendor advisory for mitigations.
References
- https://docs.gocd.org/current/configuration/pipeline_labeling.html
- https://github.com/gocd/gocd/commit/95f758229d419411a38577608709d8552cccf193
- https://github.com/gocd/gocd/commit/c6aa644973b034305bbe9ea34b010dcf5b5790ce
- https://github.com/gocd/gocd/releases/tag/23.1.0
- https://github.com/gocd/gocd/security/advisories/GHSA-3vvg-gjfr-q9vm
- https://www.gocd.org/releases/#23-1-0
- https://docs.gocd.org/current/configuration/pipeline_labeling.html
- https://github.com/gocd/gocd/commit/95f758229d419411a38577608709d8552cccf193
- https://github.com/gocd/gocd/commit/c6aa644973b034305bbe9ea34b010dcf5b5790ce
- https://github.com/gocd/gocd/releases/tag/23.1.0
- https://github.com/gocd/gocd/security/advisories/GHSA-3vvg-gjfr-q9vm
- https://www.gocd.org/releases/#23-1-0
Get alerted when CVE-2023-28629 or the next vulnerability affects your stack