What’s Vulnerable › Vulnerabilities
CVE-2023-28633: GLPI vulnerable to Blind Server-Side Request Forgery (SSRF) in RSS feeds
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-06-17
- Weakness: CWE-918
Description
GLPI is a free asset and IT management software package. Starting in version 0.84 and prior to versions 9.5.13 and 10.0.7, usage of RSS feeds is subject to server-side request forgery (SSRF). In case the remote address is not a valid RSS feed, an RSS autodiscovery feature is triggered. This feature does not check safety or URLs. Versions 9.5.13 and 10.0.7 contain a patch for this issue.
Affected products
- glpi-project glpi: from 0.84 before 9.5.13; from 10.0.0 before 10.0.7 — fixed in 10.0.7, 9.5.13
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.7, 9.5.13. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/e2819da64c9075050805a44c834e1f4dc621a982
- https://github.com/glpi-project/glpi/releases/tag/10.0.7
- https://github.com/glpi-project/glpi/releases/tag/9.5.13
- https://github.com/glpi-project/glpi/security/advisories/GHSA-r57v-j88m-rwwf
- https://github.com/glpi-project/glpi/commit/e2819da64c9075050805a44c834e1f4dc621a982
- https://github.com/glpi-project/glpi/releases/tag/10.0.7
- https://github.com/glpi-project/glpi/releases/tag/9.5.13
- https://github.com/glpi-project/glpi/security/advisories/GHSA-r57v-j88m-rwwf
Get alerted when CVE-2023-28633 or the next vulnerability affects your stack