What’s Vulnerable › Vulnerabilities
CVE-2023-28639: GLPI vulnerable to reflected Cross-site Scripting in search pages
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI is a free asset and IT management software package. Starting in version 0.85 and prior to versions 9.5.13 and 10.0.7, a malicious link can be crafted by an unauthenticated user. It will be able to exploit a reflected XSS in case any authenticated user opens the crafted link. This issue is fixed in versions 9.5.13 and 10.0.7.
Affected products
- glpi-project glpi: from 0.85 before 9.5.13; from 10.0.0 before 10.0.7 — fixed in 10.0.7, 9.5.13
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.7, 9.5.13. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/releases/tag/10.0.7
- https://github.com/glpi-project/glpi/releases/tag/9.5.13
- https://github.com/glpi-project/glpi/security/advisories/GHSA-r93q-chh5-jgh4
- https://github.com/glpi-project/glpi/releases/tag/10.0.7
- https://github.com/glpi-project/glpi/releases/tag/9.5.13
- https://github.com/glpi-project/glpi/security/advisories/GHSA-r93q-chh5-jgh4
Get alerted when CVE-2023-28639 or the next vulnerability affects your stack