What’s Vulnerable › Vulnerabilities
CVE-2023-28651
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 62.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting vulnerability exists in CONPROSYS HMI System (CHS) versions prior to 3.5.3. If a user who can access the affected product with an administrative privilege configures specially crafted settings, an arbitrary script may be executed on the web browser of the other user who is accessing the affected product with an administrative privilege.
Affected products
- Contec Co., Ltd. CONPROSYS HMI System (CHS): before 3.5.3 — fixed in 3.5.3
How to fix
Upgrade to a fixed version: Contec Co., Ltd. CONPROSYS HMI System (CHS) 3.5.3. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/vu/JVNVU93372935/
- https://www.contec.com/api/downloadlogger?download=/-/media/Contec/jp/support/security-info/contec_security_chs_230531_en.pdf
- https://www.contec.com/jp/api/downloadlogger?download=/-/media/Contec/jp/support/security-info/contec_security_chs_230531_jp.pdf
- https://jvn.jp/en/vu/JVNVU93372935/
- https://www.contec.com/api/downloadlogger?download=/-/media/Contec/jp/support/security-info/contec_security_chs_230531_en.pdf
- https://www.contec.com/jp/api/downloadlogger?download=/-/media/Contec/jp/support/security-info/contec_security_chs_230531_jp.pdf
Get alerted when CVE-2023-28651 or the next vulnerability affects your stack