What’s Vulnerable › Vulnerabilities
CVE-2023-28706: Apache Airflow Hive Provider Beeline Remote Command Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-07 · updated 2026-06-17
- Weakness: CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider: before 6.0.0.
Affected products
- Apache Airflow Hive Provider: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Apache Airflow Hive Provider 6.0.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/04/07/2
- https://github.com/apache/airflow/pull/30212
- https://lists.apache.org/thread/dl20xxd51xvlx0zzc0wzgxfjwgtbbxo3
- http://www.openwall.com/lists/oss-security/2023/04/07/2
- https://github.com/apache/airflow/pull/30212
- https://lists.apache.org/thread/dl20xxd51xvlx0zzc0wzgxfjwgtbbxo3
Get alerted when CVE-2023-28706 or the next vulnerability affects your stack