What’s Vulnerable › Vulnerabilities
CVE-2023-28707: Airflow Apache Drill Provider Arbitrary File Read Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-07 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider.This issue affects Apache Airflow Drill Provider: before 2.3.2.
Affected products
- Apache Software Foundation Apache Airflow Drill Provider: before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Drill Provider 2.3.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/04/07/1
- https://github.com/apache/airflow/pull/30215
- https://lists.apache.org/thread/dfoj7q1nd0vhhsl8fjg63z4j6mfmdxtk
- http://www.openwall.com/lists/oss-security/2023/04/07/1
- https://github.com/apache/airflow/pull/30215
- https://lists.apache.org/thread/dfoj7q1nd0vhhsl8fjg63z4j6mfmdxtk
Get alerted when CVE-2023-28707 or the next vulnerability affects your stack