What’s Vulnerable › Vulnerabilities
CVE-2023-28710: Apache Airflow Spark Provider Arbitrary File Read via JDBC
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-07 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Spark Provider.This issue affects Apache Airflow Spark Provider: before 4.0.1.
Affected products
- Apache Software Foundation Apache Airflow Spark Provider: before 4.0.1 — fixed in 4.0.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Spark Provider 4.0.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/04/07/3
- https://github.com/apache/airflow/pull/30223
- https://lists.apache.org/thread/lb9w9114ow00h2nkn8bjm106v5x1p1d2
- http://www.openwall.com/lists/oss-security/2023/04/07/3
- https://github.com/apache/airflow/pull/30223
- https://lists.apache.org/thread/lb9w9114ow00h2nkn8bjm106v5x1p1d2
Get alerted when CVE-2023-28710 or the next vulnerability affects your stack