What’s Vulnerable › Vulnerabilities
CVE-2023-28769
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-27 · updated 2026-06-17
- Weakness: CWE-120
Description
The buffer overflow vulnerability in the library “libclinkc.so” of the web server “zhttpd” in Zyxel DX5401-B0 firmware versions prior to V5.17(ABYO.1)C0 could allow a remote unauthenticated attacker to execute some OS commands or to cause denial-of-service (DoS) conditions on a vulnerable device.
Affected products
- Zyxel DX5401-B0 firmware: before 5.17\(abyo.1\)c0 — fixed in 5.17\(abyo.1\)c0
How to fix
Upgrade to a fixed version: Zyxel DX5401-B0 firmware 5.17\(abyo.1\)c0. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-multiple-vulnerabilities
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-multiple-vulnerabilities
Get alerted when CVE-2023-28769 or the next vulnerability affects your stack