What’s Vulnerable › Vulnerabilities
CVE-2023-28771: Zyxel Multiple Firewalls OS Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-05-31
- EPSS: 99.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-25 · updated 2026-06-17
- Weakness: CWE-78
Description
Improper error message handling in Zyxel ZyWALL/USG series firmware versions 4.60 through 4.73, VPN series firmware versions 4.60 through 5.35, USG FLEX series firmware versions 4.60 through 5.35, and ATP series firmware versions 4.60 through 5.35, which could allow an unauthenticated attacker to execute some OS commands remotely by sending crafted packets to an affected device.
Affected products
- Zyxel Atp100 Firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel Atp100W Firmware: from 4.60 before 5.35 — fixed in 5.35
- Zyxel Atp200 Firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel Atp500 Firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel Atp700 Firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel Atp800 Firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel firewall (ZLD): from 4.60 before 5.36 — fixed in 5.36
- Zyxel USG FLEX 100(W) firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel USG FLEX 200 firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel USG FLEX 500 firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel Usg Flex 50 Firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel USG FLEX 50(W) firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel USG FLEX 700 firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel Vpn1000 Firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel Vpn100 Firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel Vpn300 Firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel Vpn50 Firmware: from 4.60 before 5.36 — fixed in 5.36
- Zyxel Zywall Usg 100 Firmware: from 4.60 before 4.73; 4.73 — fixed in 4.73
- Zyxel Zywall Usg 310 Firmware: from 4.60 before 4.73; 4.73 — fixed in 4.73
How to fix
Upgrade to a fixed version: Zyxel Atp100 Firmware 5.36; Zyxel Atp100W Firmware 5.35; Zyxel Atp200 Firmware 5.36; Zyxel Atp500 Firmware 5.36; Zyxel Atp700 Firmware 5.36; Zyxel Atp800 Firmware 5.36; Zyxel firewall (ZLD) 5.36; Zyxel USG FLEX 100(W) firmware 5.36; Zyxel USG FLEX 200 firmware 5.36; Zyxel USG FLEX 500 firmware 5.36; Zyxel Usg Flex 50 Firmware 5.36; Zyxel USG FLEX 50(W) firmware 5.36. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/172820/Zyxel-IKE-Packet-Decoder-Unauthenticated-Remote-Code-Execution.html
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-remote-command-injection-vulnerability-of-firewalls
- http://packetstormsecurity.com/files/172820/Zyxel-IKE-Packet-Decoder-Unauthenticated-Remote-Code-Execution.html
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-remote-command-injection-vulnerability-of-firewalls
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-28771
Get alerted when CVE-2023-28771 or the next vulnerability affects your stack