What’s Vulnerable › Vulnerabilities
CVE-2023-28835: Insecure randomness for default password in nextcloud
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-30 · updated 2026-06-17
- Weakness: CWE-338
Description
Nextcloud server is an open source home cloud implementation. In affected versions the generated fallback password when creating a share was using a weak complexity random number generator, so when the sharer did not change it the password could be guessable to an attacker willing to brute force it. It is recommended that the Nextcloud Server is upgraded to 24.0.10 or 25.0.4. This issue only affects users who do not have a password policy enabled, so enabling a password policy is an effective mitigation for users unable to upgrade.
Affected products
- Nextcloud Server: from 23.0.0 before 23.0.14; from 24.0.0 before 24.0.10; from 25.0.0 before 25.0.4 — fixed in 23.0.14, 24.0.10, 25.0.4
How to fix
Upgrade to a fixed version: Nextcloud Server 23.0.14, 24.0.10, 25.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-7w2p-rp9m-9xp9
- https://github.com/nextcloud/server/pull/36093
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-7w2p-rp9m-9xp9
- https://github.com/nextcloud/server/pull/36093
Get alerted when CVE-2023-28835 or the next vulnerability affects your stack