What’s Vulnerable › Vulnerabilities
CVE-2023-28838: GLPI vulnerable to SQL injection through dynamic reports
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-06-17
- Weakness: CWE-89
Description
GLPI is a free asset and IT management software package. Starting in version 0.50 and prior to versions 9.5.13 and 10.0.7, a SQL Injection vulnerability allow users with access rights to statistics or reports to extract all data from database and, in some cases, write a webshell on the server. Versions 9.5.13 and 10.0.7 contain a patch for this issue. As a workaround, remove `Assistance > Statistics` and `Tools > Reports` read rights from every user.
Affected products
- glpi-project glpi: from 0.50 before 9.5.13; from 10.0.0 before 10.0.7 — fixed in 10.0.7, 9.5.13
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.7, 9.5.13. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/releases/tag/10.0.7
- https://github.com/glpi-project/glpi/releases/tag/9.5.13
- https://github.com/glpi-project/glpi/security/advisories/GHSA-2c7r-gf38-358f
- https://github.com/glpi-project/glpi/releases/tag/10.0.7
- https://github.com/glpi-project/glpi/releases/tag/9.5.13
- https://github.com/glpi-project/glpi/security/advisories/GHSA-2c7r-gf38-358f
Get alerted when CVE-2023-28838 or the next vulnerability affects your stack