What’s Vulnerable › Vulnerabilities
CVE-2023-28839: Improper neutralization in an SQL query in Shoppingfeed
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-18 · updated 2026-06-17
- Weakness: CWE-89
Description
Shoppingfeed PrestaShop is an add-on to the PrestaShop ecommerce platform to synchronize data. The module Shoppingfeed for PrestaShop is vulnerable to SQL injection between version 1.4.0 and 1.8.2 due to a lack of input sanitization. This issue has been addressed in version 1.8.3. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- Shoppingfeed: from 1.4.0 before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: Shoppingfeed 1.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/shoppingflux/module-prestashop/pull/209
- https://github.com/shoppingflux/module-prestashop/security/advisories/GHSA-vfmq-w777-qvcf
- https://github.com/shoppingflux/module-prestashop/pull/209
- https://github.com/shoppingflux/module-prestashop/security/advisories/GHSA-vfmq-w777-qvcf
Get alerted when CVE-2023-28839 or the next vulnerability affects your stack