What’s Vulnerable › Vulnerabilities
CVE-2023-28843: Improper neutralization of SQL parameter in PayPal module for PrestaShop
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-31 · updated 2026-06-17
- Weakness: CWE-89
Description
PrestaShop/paypal is an open source module for the PrestaShop web commerce ecosystem which provides paypal payment support. A SQL injection vulnerability found in the PrestaShop paypal module from release from 3.12.0 to and including 3.16.3 allow a remote attacker to gain privileges, modify data, and potentially affect system availability. The cause of this issue is that SQL queries were being constructed with user input which had not been properly filtered. Only deployments on PrestaShop 1.6 are affected. Users are advised to upgrade to module version 3.16.4. There are no known workarounds for this vulnerability.
Affected products
- 202ecommerce paypal: from 3.12.0 before 3.16.4 — fixed in 3.16.4
How to fix
Upgrade to a fixed version: 202ecommerce paypal 3.16.4. Check the vendor advisory for mitigations.
References
- https://github.com/202ecommerce/paypal/commit/2f6884ea1d0fe4b58441699fcc1d6c56c7d733eb
- https://github.com/202ecommerce/paypal/security/advisories/GHSA-66pc-8gh8-mx7m
- https://github.com/202ecommerce/paypal/commit/2f6884ea1d0fe4b58441699fcc1d6c56c7d733eb
- https://github.com/202ecommerce/paypal/security/advisories/GHSA-66pc-8gh8-mx7m
Get alerted when CVE-2023-28843 or the next vulnerability affects your stack