What’s Vulnerable › Vulnerabilities
CVE-2023-28849: GLPI vulnerable to SQL injection and Stored XSS via inventory agent request
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI is a free asset and IT management software package. Starting in version 10.0.0 and prior to version 10.0.7, GLPI inventory endpoint can be used to drive a SQL injection attack. It can also be used to store malicious code that could be used to perform XSS attack. By default, GLPI inventory endpoint requires no authentication. Version 10.0.7 contains a patch for this issue. As a workaround, disable native inventory.
Affected products
- glpi-project glpi: from 10.0.0 before 10.0.7 — fixed in 10.0.7
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/releases/tag/10.0.7
- https://github.com/glpi-project/glpi/security/advisories/GHSA-9r84-jpg3-h4m6
- https://github.com/glpi-project/glpi/releases/tag/10.0.7
- https://github.com/glpi-project/glpi/security/advisories/GHSA-9r84-jpg3-h4m6
Get alerted when CVE-2023-28849 or the next vulnerability affects your stack