What’s Vulnerable › Vulnerabilities
CVE-2023-28850: Pimcore Perspective Editor vulnerable to Cross-site Scripting in perspective name
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Pimcore Perspective Editor provides an editor for Pimcore that allows users to add/remove/edit custom views and perspectives. This vulnerability has the potential to steal a user's cookie and gain unauthorized access to that user's account through the stolen cookie or redirect users to other malicious sites. Version 1.5.1 has a patch. As a workaround, one may apply the patch manually.
Affected products
- pimcore perspective-editor: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: pimcore perspective-editor 1.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/perspective-editor/pull/121.patch
- https://github.com/pimcore/perspective-editor/security/advisories/GHSA-fq8q-55v3-2986
- https://huntr.dev/bounties/5529f51e-e40f-46f1-887b-c9dbebab4f06/
- https://github.com/pimcore/perspective-editor/pull/121.patch
- https://github.com/pimcore/perspective-editor/security/advisories/GHSA-fq8q-55v3-2986
- https://huntr.dev/bounties/5529f51e-e40f-46f1-887b-c9dbebab4f06/
Get alerted when CVE-2023-28850 or the next vulnerability affects your stack