What’s Vulnerable › Vulnerabilities
CVE-2023-28854: nophp vulnerable to shell command injection on httpd user when sending a password-setting mail or mail-login mail
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-03 · updated 2026-06-17
- Weakness: CWE-77
Description
nophp is a PHP web framework. Prior to version 0.0.1, nophp is vulnerable to shell command injection on httpd user. A patch was made available at commit e5409aa2d441789cbb35f6b119bef97ecc3986aa on 2023-03-30. Users should update index.php to 2023-03-30 or later or, as a workaround, add a function such as `env_patchsample230330.php` to env.php.
Affected products
- paijp nophp: before 0.0.1 — fixed in 0.0.1
How to fix
Upgrade to a fixed version: paijp nophp 0.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/paijp/nophp/commit/e5409aa2d441789cbb35f6b119bef97ecc3986aa
- https://github.com/paijp/nophp/releases/tag/v0.0.1
- https://github.com/paijp/nophp/security/advisories/GHSA-9858-q3c2-9wwm
- https://github.com/paijp/nophp/commit/e5409aa2d441789cbb35f6b119bef97ecc3986aa
- https://github.com/paijp/nophp/releases/tag/v0.0.1
- https://github.com/paijp/nophp/security/advisories/GHSA-9858-q3c2-9wwm
Get alerted when CVE-2023-28854 or the next vulnerability affects your stack