What’s Vulnerable › Vulnerabilities
CVE-2023-28856: `HINCRBYFLOAT` can be used to crash a redis-server process
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-18 · updated 2026-06-17
- Weakness: CWE-20
Description
Redis is an open source, in-memory database that persists on disk. Authenticated users can use the `HINCRBYFLOAT` command to create an invalid hash field that will crash Redis on access in affected versions. This issue has been addressed in in versions 7.0.11, 6.2.12, and 6.0.19. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 36, 37, 38
- Redis: before 6.0.19; from 6.2.0 before 6.2.12; from 7.0.0 before 7.0.11 — fixed in 6.0.19, 6.2.12, 7.0.11
How to fix
Upgrade to a fixed version: Redis 6.0.19, 6.2.12, 7.0.11. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/bc7fe41e5857a0854d524e2a63a028e9394d2a5c
- https://github.com/redis/redis/pull/11149
- https://github.com/redis/redis/security/advisories/GHSA-hjv8-vjf6-wcr6
- https://lists.debian.org/debian-lts-announce/2023/04/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/EQ4DJSO4DMR55AWK6OPVJH5UTEB35R2Z/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LPUTH7NBQTZDVJWFNUD24ZCS6NDUFYS6/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/OQGKMKSQE67L32HE6W5EI2I2YKW5VWHI/
- https://security.netapp.com/advisory/ntap-20230601-0007/
- https://github.com/redis/redis/commit/bc7fe41e5857a0854d524e2a63a028e9394d2a5c
- https://github.com/redis/redis/pull/11149
- https://github.com/redis/redis/security/advisories/GHSA-hjv8-vjf6-wcr6
- https://lists.debian.org/debian-lts-announce/2023/04/msg00023.html
Get alerted when CVE-2023-28856 or the next vulnerability affects your stack