What’s Vulnerable › Vulnerabilities
CVE-2023-28862
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-31 · updated 2026-06-17
- Weakness: CWE-287
Description
An issue was discovered in LemonLDAP::NG before 2.16.1. Weak session ID generation in the AuthBasic handler and incorrect failure handling during a password check allow attackers to bypass 2FA verification. Any plugin that tries to deny session creation after the store step does not deny an AuthBasic session.
Affected products
- lemonldap-ng Lemonldap::Ng: before 2.16.1 — fixed in 2.16.1
How to fix
Upgrade to a fixed version: lemonldap-ng Lemonldap::Ng 2.16.1. Check the vendor advisory for mitigations.
References
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/2896
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/releases/v2.16.1
- https://lists.debian.org/debian-lts-announce/2023/07/msg00018.html
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/2896
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/releases/v2.16.1
- https://lists.debian.org/debian-lts-announce/2023/07/msg00018.html
Get alerted when CVE-2023-28862 or the next vulnerability affects your stack