What’s Vulnerable › Vulnerabilities

CVE-2023-28867

Description

In GraphQL Java (aka graphql-java) before 20.1, an attacker can send a crafted GraphQL query that causes stack consumption. The fixed versions are 20.1, 19.4, 18.4, 17.5, and 0.0.0-2023-03-20T01-49-44-80e3135.

Affected products

How to fix

Upgrade to a fixed version: Graphql-Java 17.5, 18.4, 19.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-28867 or the next vulnerability affects your stack