What’s Vulnerable › Vulnerabilities
CVE-2023-28882
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-28 · updated 2026-06-17
- Weakness: CWE-400
Description
Trustwave ModSecurity 3.0.5 through 3.0.8 before 3.0.9 allows a denial of service (worker crash and unresponsiveness) because some inputs cause a segfault in the Transaction class for some configurations.
Affected products
- owasp-modsecurity ModSecurity: from 3.0.5 before 3.0.9 — fixed in 3.0.9
How to fix
Upgrade to a fixed version: owasp-modsecurity ModSecurity 3.0.9. Check the vendor advisory for mitigations.
References
- https://www.trustwave.com/en-us/resources/security-resources/software-updates/announcing-modsecurity-version-309/
- https://www.trustwave.com/en-us/resources/security-resources/software-updates/announcing-modsecurity-version-309/
Get alerted when CVE-2023-28882 or the next vulnerability affects your stack