What’s Vulnerable › Vulnerabilities
CVE-2023-29003: SvelteKit has Insufficient Cross-Site Request Forgery Protection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-04 · updated 2026-06-17
- Weakness: CWE-184
Description
SvelteKit is a web development framework. The SvelteKit framework offers developers an option to create simple REST APIs. This is done by defining a `+server.js` file, containing endpoint handlers for different HTTP methods. SvelteKit provides out-of-the-box cross-site request forgery (CSRF) protection to its users. While the implementation does a sufficient job in mitigating common CSRF attacks, prior to version 1.15.1, the protection can be bypassed by simply specifying a different `Content-Type` header value. If abused, this issue will allow malicious requests to be submitted from third-party domains, which can allow execution of operations within the context of the victim's session, and in extreme scenarios can lead to unauthorized access to users’ accounts. SvelteKit 1.15.1 updates the `is_form_content_type` function call in the CSRF protection logic to include `text/plain`. As additional hardening of the CSRF protection mechanism against potential method overrides, SvelteKit 1.15.1 is now performing validation on `PUT`, `PATCH` and `DELETE` methods as well. This latter hardening is only needed to protect users who have put in some sort of `?_method= override` feature themselves in their `handle` hook, so that the request that resolve sees could be `PUT`/`PATCH`/`DELETE` when the browser issues a `POST` request.
Affected products
- sveltejs kit: before 1.15.1 — fixed in 1.15.1
How to fix
Upgrade to a fixed version: sveltejs kit 1.15.1. Check the vendor advisory for mitigations.
References
- https://github.com/sveltejs/kit/commit/bb2253d51d00aba2e4353952d4fb0dcde6c77123
- https://github.com/sveltejs/kit/releases/tag/%40sveltejs%2Fkit%401.15.1
- https://github.com/sveltejs/kit/security/advisories/GHSA-5p75-vc5g-8rv2
- https://github.com/sveltejs/kit/commit/bb2253d51d00aba2e4353952d4fb0dcde6c77123
- https://github.com/sveltejs/kit/releases/tag/%40sveltejs%2Fkit%401.15.1
- https://github.com/sveltejs/kit/security/advisories/GHSA-5p75-vc5g-8rv2
Get alerted when CVE-2023-29003 or the next vulnerability affects your stack