What’s Vulnerable › Vulnerabilities
CVE-2023-29005: No Rate Limiting on Login AUTH DB
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-10 · updated 2026-06-17
- Weakness: CWE-307
Description
Flask-AppBuilder versions before 4.3.0 lack rate limiting which can allow an attacker to brute-force user credentials. Version 4.3.0 includes the ability to enable rate limiting using `AUTH_RATE_LIMITED = True`, `RATELIMIT_ENABLED = True`, and setting an `AUTH_RATE_LIMIT`.
Affected products
- dpgaspar Flask-AppBuilder: before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: dpgaspar Flask-AppBuilder 4.3.0. Check the vendor advisory for mitigations.
References
- https://flask-limiter.readthedocs.io/en/stable/configuration.html
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-9hcr-9hcv-x6pv
- https://flask-limiter.readthedocs.io/en/stable/configuration.html
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-9hcr-9hcv-x6pv
Get alerted when CVE-2023-29005 or the next vulnerability affects your stack