What’s Vulnerable › Vulnerabilities
CVE-2023-29010: BudiBase Server-Side Request Forgery vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-06 · updated 2026-06-17
- Weakness: CWE-918
Description
Budibase is a low code platform for creating internal tools, workflows, and admin panels. Versions prior to 2.4.3 (07 March 2023) are vulnerable to Server-Side Request Forgery. This can lead to an attacker gaining access to a Budibase AWS secret key. Users of Budibase cloud need to take no action. Self-host users who run Budibase on the public internet and are using a cloud provider that allows HTTP access to metadata information should ensure that when they deploy Budibase live, their internal metadata endpoint is not exposed.
Affected products
- budibase: before 2.4.3 — fixed in 2.4.3
How to fix
Upgrade to a fixed version: budibase 2.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/commits/develop?after=93d6939466aec192043d8ac842e754f65fdf2e8a+594&branch=develop&qualified_name=refs%2Fheads%2Fdevelop
- https://github.com/Budibase/budibase/releases/tag/v2.4.3
- https://github.com/Budibase/budibase/security/advisories/GHSA-9xg2-9mcv-985p
- https://github.com/Budibase/budibase/commits/develop?after=93d6939466aec192043d8ac842e754f65fdf2e8a+594&branch=develop&qualified_name=refs%2Fheads%2Fdevelop
- https://github.com/Budibase/budibase/releases/tag/v2.4.3
- https://github.com/Budibase/budibase/security/advisories/GHSA-9xg2-9mcv-985p
Get alerted when CVE-2023-29010 or the next vulnerability affects your stack