What’s Vulnerable › Vulnerabilities
CVE-2023-29015: Goobi viewer Core has Cross-Site Scripting Vulnerability in User Comments
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Goobi viewer is a web application that allows digitised material to be displayed in a web browser. A cross-site scripting vulnerability has been identified in the user comment feature of Goobi viewer core prior to version 23.03. An attacker could create a specially crafted comment, resulting in the execution of malicious script code in the user's browser when displaying the comment. The vulnerability has been fixed in version 23.03.
Affected products
- intranda goobi-viewer-core: before 23.03 — fixed in 23.03
How to fix
Upgrade to a fixed version: intranda goobi-viewer-core 23.03. Check the vendor advisory for mitigations.
References
- https://github.com/intranda/goobi-viewer-core/commit/f0ccde2d469efd9597c3062d00177a63341f2256
- https://github.com/intranda/goobi-viewer-core/security/advisories/GHSA-622w-995c-3c3h
- https://github.com/intranda/goobi-viewer-core/commit/f0ccde2d469efd9597c3062d00177a63341f2256
- https://github.com/intranda/goobi-viewer-core/security/advisories/GHSA-622w-995c-3c3h
Get alerted when CVE-2023-29015 or the next vulnerability affects your stack