What’s Vulnerable › Vulnerabilities
CVE-2023-29017: vm2 Sandbox Escape vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 63.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-06 · updated 2026-06-17
- Weakness: CWE-913
Description
vm2 is a sandbox that can run untrusted code with whitelisted Node's built-in modules. Prior to version 3.9.15, vm2 was not properly handling host objects passed to `Error.prepareStackTrace` in case of unhandled async errors. A threat actor could bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version 3.9.15 of vm2. There are no known workarounds.
Affected products
- patriksimek vm2: before 3.9.15 — fixed in 3.9.15
How to fix
Upgrade to a fixed version: patriksimek vm2 3.9.15. Check the vendor advisory for mitigations.
References
- https://gist.github.com/seongil-wi/2a44e082001b959bfe304b62121fb76d
- https://github.com/patriksimek/vm2/commit/d534e5785f38307b70d3aac1945260a261a94d50
- https://github.com/patriksimek/vm2/issues/515
- https://github.com/patriksimek/vm2/security/advisories/GHSA-7jxr-cg7f-gpgv
- https://gist.github.com/seongil-wi/2a44e082001b959bfe304b62121fb76d
- https://github.com/patriksimek/vm2/commit/d534e5785f38307b70d3aac1945260a261a94d50
- https://github.com/patriksimek/vm2/issues/515
- https://github.com/patriksimek/vm2/security/advisories/GHSA-7jxr-cg7f-gpgv
Get alerted when CVE-2023-29017 or the next vulnerability affects your stack