What’s Vulnerable › Vulnerabilities
CVE-2023-29018: OpenFeature Operator vulnerable to Cluster-level Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-14 · updated 2026-06-17
- Weakness: CWE-269
Description
The OpenFeature Operator allows users to expose feature flags to applications. Assuming the pre-existence of a vulnerability that allows for arbitrary code execution, an attacker could leverage the lax permissions configured on `open-feature-operator-controller-manager` to escalate the privileges of any SA in the cluster. The increased privileges could be used to modify cluster state, leading to DoS, or read sensitive data, including secrets. Version 0.2.32 mitigates this issue by restricting the resources the `open-feature-operator-controller-manager` can modify.
Affected products
- Linuxfoundation Openfeature: before 0.2.32 — fixed in 0.2.32
How to fix
Upgrade to a fixed version: Linuxfoundation Openfeature 0.2.32. Check the vendor advisory for mitigations.
References
- https://github.com/open-feature/open-feature-operator/releases/tag/v0.2.32
- https://github.com/open-feature/open-feature-operator/security/advisories/GHSA-cwf6-xj49-wp83
- https://github.com/open-feature/open-feature-operator/releases/tag/v0.2.32
- https://github.com/open-feature/open-feature-operator/security/advisories/GHSA-cwf6-xj49-wp83
Get alerted when CVE-2023-29018 or the next vulnerability affects your stack