What’s Vulnerable › Vulnerabilities
CVE-2023-29044
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Documents operations could be manipulated to contain invalid data types, possibly script code. Script code could be injected to an operation that would be executed for users that are actively collaborating on the same document. Operation data exchanged between collaborating parties does now get escaped to avoid code execution. No publicly available exploits are known.
Affected products
- Open-Xchange Appsuite: before 7.10.6; 7.10.6, 7.10.6-patch_release_6069, 7.10.6-patch_release_6073, 7.10.6-patch_release_6080, 7.10.6-patch_release_6085, 7.10.6-patch_release_6093 (+36) — fixed in 7.10.6
How to fix
Upgrade to a fixed version: Open-Xchange Appsuite 7.10.6. Check the vendor advisory for mitigations.
References
- https://documentation.open-xchange.com/appsuite/security/advisories/csaf/2023/oxas-adv-2023-0004.json
- https://software.open-xchange.com/products/appsuite/doc/Release_Notes_for_Patch_Release_6243_7.10.6_2023-08-01.pdf
- https://documentation.open-xchange.com/appsuite/security/advisories/csaf/2023/oxas-adv-2023-0004.json
- https://software.open-xchange.com/products/appsuite/doc/Release_Notes_for_Patch_Release_6243_7.10.6_2023-08-01.pdf
Get alerted when CVE-2023-29044 or the next vulnerability affects your stack