What’s Vulnerable › Vulnerabilities
CVE-2023-29055: Apache Kylin: Insufficiently protected credentials in config file
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-29 · updated 2026-06-17
- Weakness: CWE-522
Description
In Apache Kylin version 2.0.0 to 4.0.3, there is a Server Config web interface that displays the content of file 'kylin.properties', that may contain serverside credentials. When the kylin service runs over HTTP (or other plain text protocol), it is possible for network sniffers to hijack the HTTP payload and get access to the content of kylin.properties and potentially the containing credentials. To avoid this threat, users are recommended to * Always turn on HTTPS so that network payload is encrypted. * Avoid putting credentials in kylin.properties, or at least not in plain text. * Use network firewalls to protect the serverside such that it is not accessible to external attackers. * Upgrade to version Apache Kylin 4.0.4, which filters out the sensitive content that goes to the Server Config web interface.
Affected products
- Apache Software Foundation Apache Kylin: from 2.0.0 before 4.0.4 — fixed in 4.0.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 4.0.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/01/29/1
- https://lists.apache.org/thread/o1bvyv9wnfkx7dxpfjlor20nykgsoh6r
- http://www.openwall.com/lists/oss-security/2024/01/29/1
- https://lists.apache.org/thread/o1bvyv9wnfkx7dxpfjlor20nykgsoh6r
Get alerted when CVE-2023-29055 or the next vulnerability affects your stack