What’s Vulnerable › Vulnerabilities

CVE-2023-2910: A Command injection vulnerability was found on Printer service of ADM

Description

Improper neutralization of special elements used in a command ('Command Injection') vulnerability in Printer service functionality in ASUSTOR Data Master (ADM) allows remote unauthorized users to execute arbitrary commands via unspecified vectors. Affected products and versions include: ADM 4.0.6.RIS1, 4.1.0 and below as well as ADM 4.2.2.RI61 and below.

Affected products

How to fix

Upgrade to a fixed version: Tenable ASUSTOR Data Master 4.2.3.rk91. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-2910 or the next vulnerability affects your stack