What’s Vulnerable › Vulnerabilities
CVE-2023-2916: InfiniteWP Client <= 1.11.1 - Authenticated (Subscriber+) Sensitive Information Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 24.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-15 · updated 2026-06-17
- Weakness: CWE-200
Description
The InfiniteWP Client plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 1.11.1 via the 'admin_notice' function. This can allow authenticated attackers with subscriber-level permissions or above to extract sensitive data including configuration. It can only be exploited if the plugin has not been configured yet. If combined with another arbitrary plugin installation and activation vulnerability, it may be possible to connect a site to InfiniteWP which would make remote management possible and allow for elevation of privileges.
Affected products
- revmakx InfiniteWP Client: before 1.12.1 — fixed in 1.12.1
How to fix
Upgrade to a fixed version: revmakx InfiniteWP Client 1.12.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/iwp-client/tags/1.11.1/core.class.php#L365
- https://plugins.trac.wordpress.org/changeset/2925897/iwp-client#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/aa157c80-447f-4406-9e49-9cc6208b7b19?source=cve
- https://plugins.trac.wordpress.org/browser/iwp-client/tags/1.11.1/core.class.php#L365
- https://plugins.trac.wordpress.org/changeset/2925897/iwp-client#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/aa157c80-447f-4406-9e49-9cc6208b7b19?source=cve
Get alerted when CVE-2023-2916 or the next vulnerability affects your stack