What’s Vulnerable › Vulnerabilities

CVE-2023-29162

Description

Improper buffer restrictions the Intel(R) C++ Compiler Classic before version 2021.8 for Intel(R) oneAPI Toolkits before version 2022.3.1 may allow a privileged user to potentially enable escalation of privilege via local access.

Affected products

How to fix

Upgrade to a fixed version: Intel(R) Advisor software 2023.2; Intel Inspector 2023.2; Intel(R) IPP Cryptography software 2021.8; Intel(R) MPI Library for Intel(R) oneAPI HPC Toolkit 2021.10; Intel Oneapi Base Toolkit 2023.2; Intel(R) oneAPI Deep Neural Network (oneDNN) 2023.2; Intel Oneapi Math Kernel Library 2023.2; Intel Threading Building Blocks 2021.10; Intel(R) VTune(TM) Profiler software 2023.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-29162 or the next vulnerability affects your stack