What’s Vulnerable › Vulnerabilities
CVE-2023-29171: WordPress Magic Post Thumbnail Plugin <= 4.1.10 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Unauth. Reflected Cross-site Scripting (XSS) vulnerability in Magic Post Thumbnail plugin <= 4.1.10 versions.
Affected products
- Magic Post Thumbnail: before 4.1.11 — fixed in 4.1.11
How to fix
Upgrade to a fixed version: Magic Post Thumbnail 4.1.11. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/magic-post-thumbnail/wordpress-magic-post-thumbnail-plugin-4-1-10-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/magic-post-thumbnail/wordpress-magic-post-thumbnail-plugin-4-1-10-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-29171 or the next vulnerability affects your stack