What’s Vulnerable › Vulnerabilities
CVE-2023-29181
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-22 · updated 2026-10-22
- Weakness: CWE-134
Description
A use of externally-controlled format string vulnerability in Fortinet FortiOS 7.2.0 through 7.2.4, FortiOS 7.0.0 through 7.0.11, FortiOS 6.4.0 through 6.4.12, FortiOS 6.2.0 through 6.2.14, FortiOS 6.0.0 through 6.0.16, FortiOS 5.6 all versions, FortiOS 5.4 all versions, FortiOS 5.2 all versions, FortiOS 5.0 all versions, FortiOS 4.3 all versions, FortiOS 4.2 all versions, FortiOS 4.1 all versions, FortiOS 4.0 all versions, FortiPAM 1.0 all versions, FortiProxy 7.2.0 through 7.2.4, FortiProxy 7.0.0 through 7.0.10, FortiProxy 2.0.0 through 2.0.12, FortiProxy 01.02 all versions, FortiProxy 1.2 all versions, FortiProxy 01.01 all versions, FortiProxy 1.1 all versions, FortiProxy 01.00 all versions allows attacker to execute unauthorized code or commands via specially crafted command.
Affected products
- Fortinet FortiOS (FortiGate): from 6.0.0 before 6.2.15; from 6.4.0 before 6.4.13; from 7.0.0 before 7.0.12; from 7.2.0 before 7.2.5 — fixed in 6.2.15, 6.4.13, 7.0.12, 7.2.5
- Fortinet FortiPAM: from 1.0.0 before 1.1.0 — fixed in 1.1.0
- Fortinet FortiProxy: from 1.0.0 before 2.0.13; from 7.0.0 before 7.0.11; from 7.2.0 before 7.2.5 — fixed in 2.0.13, 7.0.11, 7.2.5
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.2.15, 6.4.13, 7.0.12, 7.2.5; Fortinet FortiPAM 1.1.0; Fortinet FortiProxy 2.0.13, 7.0.11, 7.2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-29181 or the next vulnerability affects your stack