What’s Vulnerable › Vulnerabilities
CVE-2023-2919: Tutor LMS <= 2.7.4 - Cross-Site Request Forgery via 'addon_enable_disable'
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-10 · updated 2026-06-17
- Weakness: CWE-352
Description
The Tutor LMS plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.7.4. This is due to missing or incorrect nonce validation on the 'addon_enable_disable' function. This makes it possible for unauthenticated attackers to enable or disable addons via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 2.7.5 — fixed in 2.7.5
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 2.7.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/tutor/trunk/classes/Ajax.php?rev=3128650#L506
- https://plugins.trac.wordpress.org/changeset/3148621/tutor/tags/2.7.5/classes/Ajax.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/992abd72-2a8e-4bda-94c2-4a7f88487906?source=cve
Get alerted when CVE-2023-2919 or the next vulnerability affects your stack