What’s Vulnerable › Vulnerabilities
CVE-2023-29212: xwiki.platform:xwiki-platform-panels-ui Eval Injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-16 · updated 2026-06-17
- Weakness: CWE-95
Description
XWiki Commons are technical libraries common to several other top level XWiki projects. Any user with edit rights can execute arbitrary Groovy, Python or Velocity code in XWiki leading to full access to the XWiki installation. The root cause is improper escaping of the included pages in the included documents edit panel. The problem has been patched on XWiki 14.4.7, and 14.10.
Affected products
- xwiki-platform: from 14.0 before 14.4.7; 14.10-rc1 — fixed in 14.4.7
How to fix
Upgrade to a fixed version: xwiki-platform 14.4.7. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/22f249a0eb9f2a64214628217e812a994419b69f#diff-a51a252f0190274464027342b4e3eafc4ae32de4d9c17ef166e54fc5454c5689R214-R217
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-c5f4-p5wv-2475
- https://jira.xwiki.org/browse/XWIKI-20293
- https://github.com/xwiki/xwiki-platform/commit/22f249a0eb9f2a64214628217e812a994419b69f#diff-a51a252f0190274464027342b4e3eafc4ae32de4d9c17ef166e54fc5454c5689R214-R217
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-c5f4-p5wv-2475
- https://jira.xwiki.org/browse/XWIKI-20293
Get alerted when CVE-2023-29212 or the next vulnerability affects your stack