What’s Vulnerable › Vulnerabilities
CVE-2023-29214: org.xwiki.platform:xwiki-platform-panels-ui Eval Injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-16 · updated 2026-06-17
- Weakness: CWE-95
Description
XWiki Commons are technical libraries common to several other top level XWiki projects. Any user with edit rights can execute arbitrary Groovy, Python or Velocity code in XWiki leading to full access to the XWiki installation. The root cause is improper escaping of the included pages in the IncludedDocuments panel. The problem has been patched on XWiki 14.4.7, and 14.10.
Affected products
- xwiki-platform: before 13.10.11; from 14.4.0 before 14.4.7; 14.10-rc1 — fixed in 13.10.11, 14.4.7
How to fix
Upgrade to a fixed version: xwiki-platform 13.10.11, 14.4.7. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/50b4d91418b4150933f0317eb4a94ceaf5b69f67
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-qx9h-c5v6-ghqh
- https://jira.xwiki.org/browse/XWIKI-20306
- https://github.com/xwiki/xwiki-platform/commit/50b4d91418b4150933f0317eb4a94ceaf5b69f67
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-qx9h-c5v6-ghqh
- https://jira.xwiki.org/browse/XWIKI-20306
Get alerted when CVE-2023-29214 or the next vulnerability affects your stack