What’s Vulnerable › Vulnerabilities
CVE-2023-29215: Apache Linkis JDBC EngineCon has a deserialization command execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-10 · updated 2026-06-17
- Weakness: CWE-502
Description
In Apache Linkis <=1.3.1, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in JDBC EengineConn Module will trigger a deserialization vulnerability and eventually lead to remote code execution. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.
Affected products
- Apache Software Foundation Apache Linkis: through 1.3.1
References
- http://www.openwall.com/lists/oss-security/2023/04/10/4
- https://lists.apache.org/thread/o682wz1ggq491ybvjwokxvcdtnzo76ls
- http://www.openwall.com/lists/oss-security/2023/04/10/4
- https://lists.apache.org/thread/o682wz1ggq491ybvjwokxvcdtnzo76ls
Get alerted when CVE-2023-29215 or the next vulnerability affects your stack