What’s Vulnerable › Vulnerabilities
CVE-2023-29216: Apache Linkis DatasourceManager module has a deserialization command execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-10 · updated 2026-06-17
- Weakness: CWE-502
Description
In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.
Affected products
- Apache Software Foundation Apache Linkis: through 1.3.1
References
- http://www.openwall.com/lists/oss-security/2023/04/10/5
- https://lists.apache.org/thread/18vv0m32oy51nzk8tbz13qdl5569y55l
- http://www.openwall.com/lists/oss-security/2023/04/10/5
- https://lists.apache.org/thread/18vv0m32oy51nzk8tbz13qdl5569y55l
Get alerted when CVE-2023-29216 or the next vulnerability affects your stack