What’s Vulnerable › Vulnerabilities
CVE-2023-29247: Stored XSS on Apache Airflow
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Task instance details page in the UI is vulnerable to a stored XSS.This issue affects Apache Airflow: before 2.6.0.
Affected products
- Apache Airflow: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/30447
- https://github.com/apache/airflow/pull/30779
- https://lists.apache.org/thread/kqf5lxmko133780clsp827xfsh4xd3fl
- https://github.com/apache/airflow/pull/30447
- https://github.com/apache/airflow/pull/30779
- https://lists.apache.org/thread/kqf5lxmko133780clsp827xfsh4xd3fl
Get alerted when CVE-2023-29247 or the next vulnerability affects your stack