What’s Vulnerable › Vulnerabilities
CVE-2023-29257: IBM Db2 code execution
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-26 · updated 2026-06-17
Description
IBM Db2 for Linux, UNIX and Windows (includes Db2 Connect Server) 10.5, 11.1, and 11.5 is vulnerable to remote code execution as a database administrator of one database may execute code or read/write files from another database within the same instance. IBM X-Force ID: 252011.
Affected products
- IBM Db2 for Linux, UNIX and Windows: from 11.1 before 11.1.4; from 11.5 before 11.5.8; 10.5, 10.5-fp1, 10.5-fp10, 10.5-fp2, 10.5-fp3, 10.5-fp3a (+13) — fixed in 11.1.4, 11.5.8
How to fix
Upgrade to a fixed version: IBM Db2 for Linux, UNIX and Windows 11.1.4, 11.5.8. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/252011
- https://security.netapp.com/advisory/ntap-20230511-0010/
- https://www.ibm.com/support/pages/node/6985691
- https://exchange.xforce.ibmcloud.com/vulnerabilities/252011
- https://security.netapp.com/advisory/ntap-20230511-0010/
- https://www.ibm.com/support/pages/node/6985691
Get alerted when CVE-2023-29257 or the next vulnerability affects your stack