What’s Vulnerable › Vulnerabilities
CVE-2023-29320: ZDI-CAN-20712: Adobe Acrobat Blacklist Bypass Design flaw
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-10 · updated 2026-06-17
- Weakness: CWE-657
Description
Adobe Acrobat Reader versions 23.003.20244 (and earlier) and 20.005.30467 (and earlier) are affected by an Violation of Secure Design Principles vulnerability that could result in arbitrary code execution in the context of the current user by bypassing the API blacklisting feature. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: from 20.001.30005 through 20.005.30516.10516; from 20.001.30005 before 20.005.30514.10514 — fixed in 20.005.30514.10514
- Adobe Acrobat DC: from 15.008.20082 before 23.003.20269 — fixed in 23.003.20269
- Adobe Acrobat Reader: from 20.001.30005 before 20.005.30516.10516; from 20.001.30005 before 20.005.30514.10514 — fixed in 20.005.30514.10514, 20.005.30516.10516
- Adobe Acrobat Reader: from 15.008.20082 before 23.003.20269 — fixed in 23.003.20269
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30514.10514; Adobe Acrobat DC 23.003.20269; Adobe Acrobat Reader 20.005.30514.10514, 20.005.30516.10516; Adobe Acrobat Reader 23.003.20269. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb23-30.html
- https://helpx.adobe.com/security/products/acrobat/apsb23-30.html
Get alerted when CVE-2023-29320 or the next vulnerability affects your stack